summaryrefslogtreecommitdiffstats
path: root/testing/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'testing/CMakeLists.txt')
-rw-r--r--testing/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/testing/CMakeLists.txt b/testing/CMakeLists.txt
index 84162ea..97b4868 100644
--- a/testing/CMakeLists.txt
+++ b/testing/CMakeLists.txt
@@ -1,3 +1,8 @@
+add_custom_target(tests
+ COMMENT "Running doxygen tests..."
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --all --doxygen ${PROJECT_BINARY_DIR}/bin/doxygen --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
+ DEPENDS doxygen
+)
add_test(NAME suite
COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --all --doxygen $<TARGET_FILE:doxygen> --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
)