summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles-François Natali <neologix@free.fr>2013-01-08 19:03:07 (GMT)
committerCharles-François Natali <neologix@free.fr>2013-01-08 19:03:07 (GMT)
commitcd18e78897eb2a776bba62c30aac87b57e3a7579 (patch)
tree37362d9d57a403136ceaec7ac3fb955178967328 /configure.ac
parentf43c4d66bed0be1d0d7172ece317b7a836cbaa8f (diff)
parent1aa004b45dbfb1c8512c179bd7d3a35410df8b82 (diff)
downloadcpython-cd18e78897eb2a776bba62c30aac87b57e3a7579.zip
cpython-cd18e78897eb2a776bba62c30aac87b57e3a7579.tar.gz
cpython-cd18e78897eb2a776bba62c30aac87b57e3a7579.tar.bz2
Issue #16836: Enable IPv6 support even if IPv6 is disabled on the build host.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 3 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index ddbbcdf..b1e473a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2501,25 +2501,15 @@ AC_ARG_ENABLE(ipv6,
[
dnl the check does not work on cross compilation case...
- AC_RUN_IFELSE([AC_LANG_SOURCE([[ /* AF_INET6 available check */
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ /* AF_INET6 available check */
#include <sys/types.h>
-#include <sys/socket.h>
-main()
-{
- if (socket(AF_INET6, SOCK_STREAM, 0) < 0)
- exit(1);
- else
- exit(0);
-}
-]])],[
+#include <sys/socket.h>]],
+[[int domain = AF_INET6;]])],[
AC_MSG_RESULT(yes)
ipv6=yes
],[
AC_MSG_RESULT(no)
ipv6=no
-],[
- AC_MSG_RESULT(no)
- ipv6=no
])
if test "$ipv6" = "yes"; then