summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-02-11 13:27:59 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-02-11 13:27:59 (GMT)
commit25e192cc5fc52996ebbe454c187e93ae55d8d943 (patch)
treefb1ac0d904f149f0c9a1b4850c631118dfd46b77 /configure.in
parentd8244f5cdda1b4111bef3a831e138e7749a2bdd7 (diff)
downloadcpython-25e192cc5fc52996ebbe454c187e93ae55d8d943.zip
cpython-25e192cc5fc52996ebbe454c187e93ae55d8d943.tar.gz
cpython-25e192cc5fc52996ebbe454c187e93ae55d8d943.tar.bz2
Merged revisions 78154 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r78154 | ronald.oussoren | 2010-02-11 14:26:54 +0100 (Thu, 11 Feb 2010) | 2 lines Finish fix for issue 7715, after explicit search for calls to `arch` ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index aa9f45d..635dc70 100644
--- a/configure.in
+++ b/configure.in
@@ -996,7 +996,7 @@ yes)
cur_target='10.5'
fi
else
- if test `arch` = "i386"; then
+ if test `/usr/bin/arch` = "i386"; then
# On Intel macs default to a deployment
# target of 10.4, that's the first OSX
# release with Intel support.
@@ -1585,7 +1585,7 @@ case $ac_sys_system/$ac_sys_release in
if test "${enable_universalsdk}"; then
:
else
- LIBTOOL_CRUFT="${LIBTOOL_CRUFT} -arch_only `arch`"
+ LIBTOOL_CRUFT="${LIBTOOL_CRUFT} -arch_only `/usr/bin/arch`"
fi
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
@@ -1612,7 +1612,7 @@ case $ac_sys_system/$ac_sys_release in
ac_osx_32bit=yes)
if test "${ac_osx_32bit}" = "yes"; then
- case `arch` in
+ case `/usr/bin/arch` in
i386)
MACOSX_DEFAULT_ARCH="i386"
;;
@@ -1624,7 +1624,7 @@ case $ac_sys_system/$ac_sys_release in
;;
esac
else
- case `arch` in
+ case `/usr/bin/arch` in
i386)
MACOSX_DEFAULT_ARCH="x86_64"
;;