summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-11-24 15:30:27 (GMT)
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-11-24 15:30:27 (GMT)
commiteb78e0a5636354b270f581389cfb4b30d0a8f840 (patch)
treea22d20b463032514bf9efc823f49145d27ee5772 /release.nix
parent9e533f3a5182dd5663f1cf5d08303f44cafe1230 (diff)
downloadpatchelf-eb78e0a5636354b270f581389cfb4b30d0a8f840.zip
patchelf-eb78e0a5636354b270f581389cfb4b30d0a8f840.tar.gz
patchelf-eb78e0a5636354b270f581389cfb4b30d0a8f840.tar.bz2
* Simplify.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix35
1 files changed, 13 insertions, 22 deletions
diff --git a/release.nix b/release.nix
index 7595ba6..fbeef2a 100644
--- a/release.nix
+++ b/release.nix
@@ -4,47 +4,40 @@ let jobs = rec {
tarball =
{ patchelfSrc ? {path = ./.;}
, nixpkgs ? {path = ../nixpkgs;}
- , release ? {path = ../release;}
}:
- with import "${release.path}/generic-dist" nixpkgs.path;
+ with import nixpkgs.path {};
- makeSourceTarball {
- inherit (pkgs) stdenv;
+ releaseTools.makeSourceTarball {
name = "patchelf-tarball";
src = patchelfSrc;
- buildInputs = [pkgs.autoconf pkgs.automake pkgs.pan];
};
coverage =
{ tarball ? {path = jobs.tarball {};}
, nixpkgs ? {path = ../nixpkgs;}
- , release ? {path = ../release;}
}:
- with import "${release.path}/generic-dist" nixpkgs.path;
-
- coverageAnalysis {
- inherit (pkgs) stdenv;
+ with import nixpkgs.path {};
+
+ releaseTools.coverageAnalysis {
name = "patchelf-coverage";
- src = tarball.path;
+ src = tarball;
};
build =
{ tarball ? {path = jobs.tarball {};}
, nixpkgs ? {path = ../nixpkgs;}
- , release ? {path = ../release;}
, system ? "i686-linux"
}:
- with import "${release.path}/generic-dist" nixpkgs.path;
+ with import nixpkgs.path {inherit system;};
- nixBuild {
- inherit (pkgsFun {inherit system;}) stdenv;
+ releaseTools.nixBuild {
name = "patchelf-build";
- src = tarball.path;
+ src = tarball;
postInstall = ''
echo "doc readme $out/share/doc/patchelf/README" >> $out/nix-support/hydra-build-products
'';
@@ -54,16 +47,14 @@ let jobs = rec {
rpm =
{ tarball ? {path = jobs.tarball {};}
, nixpkgs ? {path = ../nixpkgs;}
- , release ? {path = ../release;}
}:
- with import "${release.path}/generic-dist" nixpkgs.path;
+ with import nixpkgs.path {};
- rpmBuild {
- inherit (pkgs) stdenv;
+ releaseTools.rpmBuild {
name = "patchelf-rpm";
- src = tarball.path;
- diskImage = diskImages_i686.fedora9i386;
+ src = tarball;
+ diskImage = vmTools.diskImages.fedora9i386;
};