summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-11-26 14:43:56 (GMT)
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-11-26 14:43:56 (GMT)
commitf8a7fd669c381a20595a75a5126aa52814aaa1d7 (patch)
treedb50d0a4f7621bb9094c7ae706f9d2edc74a141b /release.nix
parent531870e598fa372451aac1fc08403682ba37e7bc (diff)
downloadpatchelf-f8a7fd669c381a20595a75a5126aa52814aaa1d7.zip
patchelf-f8a7fd669c381a20595a75a5126aa52814aaa1d7.tar.gz
patchelf-f8a7fd669c381a20595a75a5126aa52814aaa1d7.tar.bz2
* Different priorities for jobs.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix110
1 files changed, 64 insertions, 46 deletions
diff --git a/release.nix b/release.nix
index 66037fa..1d1cc90 100644
--- a/release.nix
+++ b/release.nix
@@ -1,66 +1,83 @@
-let jobs = rec {
+let
- tarball =
- { patchelfSrc ? {path = ./.; rev = 1234;}
- , nixpkgs ? {path = ../nixpkgs;}
- , officialRelease ? false
- }:
-
- with import nixpkgs.path {};
-
- releaseTools.makeSourceTarball {
- name = "patchelf-tarball";
- src = patchelfSrc;
- inherit officialRelease;
- };
+ jobs = rec {
- coverage =
- { tarball ? {path = jobs.tarball {};}
- , nixpkgs ? {path = ../nixpkgs;}
- }:
+ tarball =
+ { patchelfSrc ? {path = ./.; rev = 1234;}
+ , nixpkgs ? {path = ../nixpkgs;}
+ , officialRelease ? false
+ }:
- with import nixpkgs.path {};
-
- releaseTools.coverageAnalysis {
- name = "patchelf-coverage";
- src = tarball;
- };
+ with import nixpkgs.path {};
+ releaseTools.makeSourceTarball {
+ name = "patchelf-tarball";
+ src = patchelfSrc;
+ inherit officialRelease;
+ };
- build =
- { tarball ? {path = jobs.tarball {};}
- , nixpkgs ? {path = ../nixpkgs;}
- , system ? "i686-linux"
- }:
- with import nixpkgs.path {inherit system;};
+ coverage =
+ { tarball ? {path = jobs.tarball {};}
+ , nixpkgs ? {path = ../nixpkgs;}
+ }:
- releaseTools.nixBuild {
- name = "patchelf-build";
- src = tarball;
- postInstall = ''
- echo "doc readme $out/share/doc/patchelf/README" >> $out/nix-support/hydra-build-products
- '';
- };
+ with import nixpkgs.path {};
+
+ releaseTools.coverageAnalysis {
+ name = "patchelf-coverage";
+ src = tarball;
+ };
+
+
+ build =
+ { tarball ? {path = jobs.tarball {};}
+ , nixpkgs ? {path = ../nixpkgs;}
+ , system ? "i686-linux"
+ }:
+
+ with import nixpkgs.path {inherit system;};
+
+ releaseTools.nixBuild {
+ name = "patchelf-build";
+ src = tarball;
+ postInstall = ''
+ echo "doc readme $out/share/doc/patchelf/README" >> $out/nix-support/hydra-build-products
+ '';
+ };
- rpm =
+ rpm_fedora9i386 = makeRPM (diskImages: diskImages.fedora9i386) 50;
+ rpm_fedora10i386 = makeRPM (diskImages: diskImages.fedora10i386) 40;
+
+
+ deb_debian40i386 = makeDeb (diskImages: diskImages.debian40i386) 30;
+ deb_ubuntu804i386 = makeDeb (diskImages: diskImages.ubuntu804i386) 40;
+
+
+ };
+
+
+ makeRPM =
+ diskImageFun: prio:
{ tarball ? {path = jobs.tarball {};}
, nixpkgs ? {path = ../nixpkgs;}
}:
with import nixpkgs.path {};
- releaseTools.rpmBuild {
- name = "patchelf-rpm";
+ releaseTools.rpmBuild rec {
+ name = "patchelf-rpm-${diskImage.name}";
src = tarball;
- diskImage = vmTools.diskImages.fedora9i386;
+ diskImage = diskImageFun vmTools.diskImages;
+ meta = { schedulingPriority = toString prio; };
};
-
- deb =
+
+ makeDeb =
+ diskImageFun: prio:
{ tarball ? {path = jobs.tarball {};}
, nixpkgs ? {path = ../nixpkgs;}
}:
@@ -70,8 +87,9 @@ let jobs = rec {
releaseTools.debBuild {
name = "patchelf-deb";
src = tarball;
- diskImage = vmTools.diskImages.debian40i386;
+ diskImage = diskImageFun vmTools.diskImages;
+ meta = { schedulingPriority = toString prio; };
};
-
-}; in jobs
+
+in jobs